Effective Solutions — QBSalesData Release Notes Document

QBSalesData Version 2.0.7.3 Release Notes

Overview of Fixes and Enhancements included in this build:

1.

New QB Create/Link Button Functionality (added in 2.0.7.2): The QB Create/Link
button has been updated to provide faster performance and more search capabilities when linking to
existing QB records. The 2.0.7.3 version also make this function more efficient. See the example
below.

When you click on the QB Create/Link button you will get the following window that appears. Click on the
LINK button to do a manual link to an existing QB Customer record.

|: Link, :|

4

QBSalesData will use the ACT Company and Contact fields to search for a match in Quickbooks. If it
finds a match, it will display the matching QB records in the list. Otherwise you can type in what to search
for in the QB Customer list and click on the SEARCH button.

AdvancedLink =101 x|

Search —— If a match is found, it will be
’7]8 Cuztomer Mame Isuppl_l,l displayed in the list. Otherwise
you can type in what to search for

y and click on the Search button. It
Customeniiane | Someagyhlane \'\\ will do a “contains” type search,
ABC Supply meaning it will look for the text
Modern Electric Sunpl Modosn EZers | anywhere in the Quickbooks
odern Electric Supply o M Customer Name. When you find
the QB record you want to link to,

select it from the list and click on
the LINK button.

ER

| Lirk: | | Cancel |

4

Highlight the row and click on the LINK button when you have found the QB record you want to link to.

2. Additional Calculated Sales Fields: We have added the following Calculated Sales fields to

the QBSalesData program:
a. STFirstinvoiceDate: This is the date of the oldest invoice listed in the QB Transactions Tab

b. STAvgSaleAmt: This is the Average Sale Amount for the transactions that exist in the QB
Transactions Tab

c. STTotal: This is the total of all of the sales that exist in the QB Transactions Tab. Another
way to look at this would be the Lifetime Sales Amount.

Note: You will need to go into Tools > QBSalesData Import, click on the BUILD FIELDS button, and
check the Contact Fields option to add these new fields to your ACT database. You will then also need to
go into Tools > Design Layouts > Contact to add the fields to your ACT layout. The fields will then be
populated the next time you run a Transaction Sync, or click on the REFRESH DATA FROM QB option
for that contact.
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New LOOKUP ITEM button: This was a highly requested feature from our customer base.
This button gives you the ability to search through the QB Items tab and lookup all customers that

purchased a particular QB Item for a specific date range in ACT. This then gives you the ability to up-

sell or cross-sell to these customers from ACT using an email blast, mail merge, label print, etc.

The LOOKUP ITEM button will show up both on the QBSalesData toolbar and within the QB Items tab.

5 Detailview | & Lstview |4 4 7of8 B Pl |U L & [ o @
(1B Create/Link Customer = Invoice = Edit Becord in QB Refresh Data From QB Lookup ltem

User Fields I QE Data I QE Transactions QB Items |Marketing Results I

Shaw Credit Mema, Invoices, Est... IEI Filker By A&l |E| l: Lookup Item :I

Drag a column header here to group by that column

Ackivities I Cipportunities I Hiskary I Motes | Documents I Groups/iCompanies I Secondary Conkacks I Relationships I web Info I Personal Info | Contack Acce:

| Irrvnice | Inwaoice Date | Tkern Murn | Itern Desc | Qby Price: Arnounk

3
}> 29 31512008 Consulting-100 Consulting Services | 10 100 1000

When you click on the LOOKUP ITEM button, you will get the following dialog box:

Lookup Contacts =131 x| Type in all or part of the QB item name
to search for. It will do a “contains”
—Search for |_—| search.
Tkem IDE" Server «—
[ Filter by Date
Start Date 112010 < EI You can also specify a date range for
ol 6/4/2010 E' when the QB Item was purchased.

k. Cancel
' P

So, in this example, | want to pull up all customers that bought a Dell Server between 1/1/2010 and

6/4/2010. When you click OK, you will get a list of contacts that match the criteria in ACT. They become

your “current lookup” in ACT.

ABC b achinemny Tom Truck tilwaukes
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ABC Baby Supplies Jaohn Pampers Brookfield |




Effective Solutions — QBSalesData Release Notes Document

4. Ability to Convert ACT! Opportunities to QB Transactions: (This Feature only works
with ACT! 2010 and higher because it has enhanced Opportunity functionality built into it)

This new functionality allows the ACT Sales User to create an Opportunity in ACT!, select Quickbooks
Items from the ACT! product tab, and when the timing is right, the Opportunity can then be converted to a
QB Transaction (Estimate, Invoice, Sales Order, Sales Receipt) with a click of a button.

There is no easy way to update existing ACT Opportunities so they can be converted to QB Transactions.
We recommend using this new process for all future Opportunities created.

How to get the Opportunities to QB Transactions process setup on your ACT! 2010 system:

1. From ACT, go to Tools > QBSalesData Import and click on the Build Fields button, and say YES
when prompted.

2. Check the box for Opportunity fields, enter in the ACT login info and click on the BUILD FIELDS
button, and the specific Opportunity fields needed for QBSalesData will be built.

3. Close out of ACT and go back in after the Build Fields program has completed.

4. Goto Tools > Design Layouts > Opportunity and add the following fields to the Opportunity
Layout so you can see them on the Opportunity screen in ACT:

MR e =
QBTransID | B _TransD =
QB Trans Type | QB _Type =l

Your ACT! 2010 system is now setup and ready to utilize the new Opportunity to QB Transaction
features.

Copying the Quickbooks Item list into the Product List in ACT!

One of the key components of the process is having your Quickbooks Items listed in the ACT Opportunity
Product list. We have a function that copies your QB item list into the ACT Opportunity Product List.

1. From ACT, go to Tools > QBSalesData Import

Sunc [k
2. Click on the SYNC ITEMS button MI in the lower right of the window.

3. A status of “Updating ACT! Product List” will appear in the lower left while the QB Items are being
copied down to ACT.

4. When the process is complete, you will get a “Sync Complete” message.
5.  When complete, all of your QB items exist within the ACT Products list.

6. To verify, you can go to the Opportunities section of ACT (View > Opportunities). And then go to
(Opportunities > Manage Product List) and that will pull up the product list in ACT.

Note: Each time you run the SYNC ITEMS function it will copy down any new QB Items and also make
updates to existing QB ltems that may have been changed (description, price). The new nightly sync
program will also have a checkbox to run the Sync ltems every night as well.
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Here is what the Product List looks like in ACT with the QB items copied down. Notice that the ltem
Number, Item Description, and Price came down for all QB Items. If you have Inventory Parts in
Quickbooks, then the Cost will also come down into ACT.

-'.j Manage Product List

Enter product list items:

Mame Itern Hurber Cost Frice
EACT 2010 Corporate

dda

ACT 2070 Standard Software ACT 2010 Standard £0.00 $200.00 Delete
Adobe Photashop software Adobe Photoshop $0.00 $259.00

Backup Exec Software. Backup Exec $0.00 $695.00 Imnport
Coarmputer Kevboard Keyboard $5.00 $15.00

Computer Mouze Mouse $10.00 $20.00 Etegrll
Consulting Services 100 Caonsulting-100 $0.00 $100.00

Conzulting Services 125 Conzulting-125 £0.00 $126.00

Conzulting Services 150 Conzulting-150 £0.00 $150.00

Dell Server Dell Server $0.00 $4,000.00

Laptop Computer Laptop Computer $0.00 $500.00

S Office 2007 Software MS Office 2007 £0.00 $300.00

S Office 2010 MS Office 2010 £0.00 $350.00

[BSalezD ata Software License [QBSalesData $0.00 $153.00

1| [

ok I Cancel

Creating an Opportunity in ACT! that can be converted to a QB Transaction

First thing to note is the user/workstation that is creating the opportunity needs to have a QBSalesData
license in order for the process to work.

1. Pull up the contact in ACT that you want to create an Opportunity for.
2. Go to the Opportunities tab and click on the NEW OPPORTUNITY button

3. ACT will jump you to the New Opportunity screen. If the contact was linked to Quickbooks, than
the QB ID number on the Opportunity will be filled in, otherwise it will say NOID.

4. Go to the Products tab of the Opportunity and click on the ADD button.

5. The first time you see this screen, you will have more fields than you need. Click on the
DISPLAY FIELDS button to adjust the fields that show up to match the list below:
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xl

Available fields: Show as columns in this order;

Adjusted Price Ttem #

Cost Marne

Create Date Quankity

Discounk Price Move Up
Discount Type Subtotal

Edit Date eloidss Losian |
Tvpe

==

2l |

<<

Reset | QK Cancel

6. When you click OK, your data entry screen will look like the one below. This should work just fine
for most companies,

Add/Edit Product X

lizin Adobe Phatosh > :
| &dobe Phatoshop ‘\I\ Select your QB Item from the list.
M arme Adobe Photoshon soft - When you hit TAB, the Name and
I S bl =l price will auto-populate. Then update
Quartity [3.00000 «— | your quantity and you are done with
entering this product in ACT. This is
Frice |$259.DD the equivalent to a line item on an
invoice in Quickbooks.

Subtatal [$777.00

Dizplay Fields. . Ok LCancel

7. The user can click on the ADD button again on the Products tab to add more line items to the
Opportunity.

8. Below is an example of a Products tab that has multiple line items created in ACT.

Contacks I Groups/iCompanies Products)Services |Nntes I Activitiesl Histnryl Documents I Opportunity InFnI Opporbunity P.ccessl User Fields

@&dd... @Qelete Ciptions
ltem # M arme 7 [uiantity I Subtatal
Adobe Photoshop Adobe Photoshop software $253.00 FFFF00
Congulting-125 Conzulting Services 125 4.00 $500.00
45 Office 2010 MS Office 20010 200 $350.00 $700.00

9. At this point the user can fill out any other fields related to the Opportunity (stage, process, etc)
and manage that opportunity. Once the Opportunity is sold, you will be able to convert it to a
Quickbooks transaction.

10. If the user wants to generate a quote from ACT, they can use the Create Quote feature
(Opportunity > Create Quote). The ACT quote template is pretty limited. If you need more
advanced quote template/merge functionality, we can recommend some 3" party addons for you.
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Converting an ACT Opportunity to a QB Transaction

When the time is right (deal is sold, time to create estimate, etc.) you can quickly convert an Opportunity
to a Quickbooks transaction.

In order to perform this conversion, you need to be on a workstation that has Quickbooks Installed as well
as QBSalesData. What will normally happen is the Salesperson will create and maintain the Opportunity

in ACT, and a back office person that has Quickbooks on their computer will lookup Opportunities that are
WON and convert them to Quickbooks transactions.

Converting a Single Opportunity from the Detail View in ACT!

1. Pull up the Opportunity in ACT that needs to be converted.

2. When you are on the Detail view of that opportunity, you will have a QBSalesData toolbar with the
following options for converting:

ACT! Premium

s || &) Detail Wiew | []] Lisk Wiew 1of3

Corrvert Tao lnvoice | - | Edit Tranzaction in B8

Convverk To Invoice —
nd M5 Office pro
Converk To Estimate

Convert To Sales Qrder

Convert To Sales Receipk

TSI | E LG

ties

3. Choose the appropriate conversion option.
4. The QB transaction will be created and you will be prompted with the following window:

Opportunity to Invoice 5[

? ) Irvoice Created, Cpen in Quickbooks Mow?
T

Yes Mo |

5. If you choose yes, it will bring up the transaction in Quickbooks that you just created.

6. In addition, the QB Trans ID and QB Trans Type fields are also updated for the opportunity, giving
you a record that it was converted and what it was converted to.

QB ID | son0n075-1258230709

QE Trans ID | 2c4-1275629545
QB Trans Type I Invoice

Edit Tranzaction in QB

7. Once the Opportunity is converted, you can use the on the QBSalesdata toolbar

to pull up the transaction in Quickbooks.
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Converting a Multiple Opportunities from the Opportunity List View in ACT!

You also have the option of converting a whole chunk of opportunities all at once. You could for example
lookup all Opportunities that are WON, but have a blank QB Trans ID or QB Trans Type, meaning they
haven’t been converted to QB Transactions yet.

Here is how to convert from the Opportunity List

1. Select the Opportunities from the list that you want to convert. Notice the ones in the screen shot
below don’t have a Trans ID or Trans Type, telling me they have not been converted yet.

2. Click on the CONVERT TO button on the QBSalesData toolbar, and select the type of QB
Transaction you would like to create.

T : : = & 5 7l 5
ACTL..... . @ e | B E Q | & ¥ = @
e Premium Mew Call Meeting To-Dio Moke History Loakup Search Wrike E-mail | Wiew E-mail | Help Topics
» | A Detall View Listiew | [4 4 1o0f5 | & E @ & & % F
i Corwert To lnvaice |~ | Edit Transaction in OB
L Convert To Invoice Options =
i essfStage— | Frobabilit Total
Convert To Estimate {Stag o 1.3 e |
icess: Inn vl @ gl @ al
Canwvert To Sales Order a =
% Convert To Sales Recelpt = v ;I Single Yalue: l_% Single value: |4 e |
= £~ Greater Than: |—°.-’o " Greater Than: |4
é £~ Less Than: |—°.-’o " Less Than: i3
2| Total $16,140.00
8 Record Manager GB_TransID 4| OB_Tupe
John Pampers  |ABC Baby Supplies | Closed -'wfon New Opportu 1 $2.518.00| admin 80000053-1275504276 2B5-1275507034 | Invoice
Bob Mevers ABC Electric Cloged - WWon New Server Initial Communication $3.700.00 | admin S0000067-1256134314 | ZBB-1275507183 | Invoice
John Tarting ABLC Roofing Claged - \Won Photoshop and M5.. | Initial Communication $1.977.00| admin 80000075-1258230709 2041275629546 | Invoice

3. With each QB transaction created, you will get the following prompt:

Opportunity to Invoice ﬂ
\;:) Invoice Created, Open in Quickbooks Mow?

Yes Mo |

4. You can click on NO and it will process the next one in the list, and you just repeat until all of the

transactions are created. You will see that the Trans ID and Trans Type get filled in for each one
created.

5. Once the Opportunities are converted, you can use the [E3tT1amsastioninB8 v, OBSalesData
toolbar to pull up the transaction in Quickbooks if necessary.
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